Home network vs. coronavirus

In questo (brutto) periodo vedo la performance si rete scendere progressivamente…

Ho una VDSL 30d/10u (FTTC, ma sono lontano dal cabinet) quindi già di per se non un gran che, se poi aggiungiamo il fatto che ormai tutti devono lavorare da casa possiamo capire la mia preoccupazione e il mio intento di aumentare banda e resilienza.

Dato che ho una sim (solo dati, con 10GB/mese di datacap) che uso poco o nulla ho pensato di dedicare un telefono a farmi da “rete di sicurezza” sia come AP portatile sia come ridondanza per il mio router di casa.

Il mio router di casa (un Linksys WRT1900AC) fa girare OpenWrt (oggi alla versione 19.07.1) da sempre e scartabellando nella documentazione si scopre che supporta usb tethering:

https://openwrt.org/docs/guide-user/network/wan/smartphone.usb.tethering

Quindi ho banalmente seguito quelle istruzioni collegando il telefono alla porta usb e attivando su Android il tethering usb, openwrt si accorge subito del device.

In /etc/config/network ho aggiunto:

config interface 'awan'
	option proto 'dhcp'
	option ifname 'usb0'
	option metric '1000'

(metric alto per far preferire quella “standard” eth1 nel mio caso)

Per attivare il load balancing (cioè il bilanciamento nell'uso delle due reti “cellulare” e “cavo”) si usa ad esempio il package 'mwan3' che gestisce il bilanciamento per connessione (e non per pacchetto). Il file di configurazione è /etc/config/mwan3, il mio è:

config interface 'wan'
	option count '1'
	option timeout '2'
	option down '3'
	option up '8'
	option reliability '1'
	list track_ip 'atrent.it'
	option initial_state 'online'
	option family 'ipv4'
	option track_method 'ping'
	option size '56'
	option check_quality '0'
	option failure_interval '5'
	option recovery_interval '5'
	option enabled '1'
	option max_ttl '60'
	option interval '10'

config interface 'awan'
	option reliability '1'
	option count '1'
	option timeout '2'
	option interval '10'
	option down '3'
	option up '8'
	list track_ip '192.168.42.129'
	option enabled '1'
	option initial_state 'online'
	option family 'ipv4'
	option track_method 'ping'
	option size '56'
	option max_ttl '60'
	option check_quality '0'
	option failure_interval '5'
	option recovery_interval '5'

config member 'wan_m10_w10'
	option interface 'wan'
	option metric '10'
	option weight '10'

config member 'awan_m20_w20'
	option interface 'awan'
	option metric '20'
	option weight '20'

config policy 'wan_only'
	list use_member 'wan_m10_w10'

config policy 'awan_only'
	list use_member 'awan_m20_w20'

config policy 'balanced'
	list use_member 'wan_m10_w10'
	list use_member 'awan_m20_w20'
	option last_resort 'unreachable'

config rule 'default_rule'
	option dest_ip '0.0.0.0/0'
	option use_policy 'balanced'

config rule 'unicredit'
	option sticky '1'
	option ipset 'unicredit'
	option dest_port '80,443'
	option proto 'tcp'

config rule 'unimi'
	option sticky '1'
	option ipset 'unimi'
	option dest_port '80,443'
	option proto 'tcp'

config globals 'globals'
	option local_source 'none'

Funziona, qualche megabit lo “aggiungo” (non si somma al preesistente) e ho aumentato la robustezza: se la FTTC cade posso usare il canale di emergenza in automatico, mwan3 si accorge che un canale non va e redirige tutto su quello che va.

Ultima nota: disattivare il wifi sul cellulare se per caso lo avete normalmente collegato al wifi di casa, altrimenti il cellulare tenta di usare il wifi di casa per… fornire rete al router wifi di casa ;-)

Se non volete configurare editando i file potete installare il package 'luci-app-mwan3' che vi aggiunge una pagina di gestione in 'luci'.

You could leave a comment if you were logged in.